A apărut WordPress 5.0, care vine cu un nou editor de text by default. Gutenberg (aşa se numeşte) a fost prezentat încă din vară şi oferit ca plugin opţional tocmai pentru a pregăti această schimbare.

Din păcate, sunt o mulţime de teme şi pluginuri care nu sunt compatibile cu acest editor, ceea ce vă poate provoca o grămadă de bătăi de cap inutile. Recomandarea mea ar fi să nu săriţi să-l instalaţi. În general, trecerea de la o versiune majoră la alta (cum e acum de la 4.x.x la 5.x.x) poate cauza probleme neprevăzute, indiferent de cât de mult a fost testată, aşa că de multe ori să apară un nou update foarte rapid. (ar fi 5.0.1 în cazul nostru).

Dacă vreţi, totuşi, să faceţi update, există două variante să dezactivaţi Gutenberg.

Prima, cea “oficială” este instalarea unui plugin numit “Classic Editor”, care vă introduce o nouă opţiune, pe lângă Gutenberg. Vedeţi mai jos cum arată, în funcţie de editorul folosit apare un text după titlu.

Varianta a doua, mult mai clean, este să folosiţi pluginul Disable Gutenberg pentru a reveni la editorul clasic fără să aveţi mai multe opţiuni de editor (mie mi se pare enervantă prima variantă de fix).

M-am jucat puţin cu Gutenberg şi nu pot să spun că mă dă pe spate, mă aşteptam să fie mult mai potent. Nu se compară cu WPBakery Page Builder. WPBakery (denumit înainte Visual Composer) e, până la urmă, un plugin premium de 45 de dolari, însă nu cred că are sens să vă chinuiţi cu un editor care e abia la începutul perioadei de dezvoltare aşa cum e Gutenberg.

Dacă chiar vreţi să faceţi chestii mai bine daţi cei 45 de dolari şi aţi rezolvat problema.